ネットワークエンジニア系ブログ。健康、エンターテイメント、映画・ドラマ、本、キッズ系、FXまで!お役立ち情報を紹介!

GOISBLOG

ネットワーク技術

Cisco OSPF設定(デュアルスタック)簡単コマンド!

更新日:

ネットワークエンジニアなら一度は設定する、OSPFです。
IPv4、IPv6の設定コマンドをメモってますのでご紹介します。

IPv6の設定において、アドレス体系は覚えれば簡単なので、覚えれば設定はIPv4と変わらないので、慣れればなんでもないですよ。

CiscoのIPv6は特別な設定無し。少し触ればすぐに覚えます。

構成図

Cisco_OSPF

Cisco OSPFv3はネットワークコマンドの設定では無く、直接interfaceへ設定する。
また、ルータID(IPv4で)を定義しないとOSPFv3は上がらない。
OSPFv3でパッシブを設定する際は"ipv6 router ospf xxx"配下で設定をする。


TVでも話題になった自宅で無料でオンラインブートキャンプが体験できるようになりました!
※資料ダウンロード(無料)はこちらから!
【CodeCamp(コードキャンプ)】公式案内



ルータAの設定例

interface Loopback0
ip address 3.3.3.3 255.255.255.255
ipv6 address 2002:c0a8:FFFF:FFFF::3/128
ipv6 ospf 100 area 0
interface GigabitEthernet0/2
description "routerB"
ip address 192.168.1.2 255.255.255.0
ip ospf cost 5
ipv6 address 2002:c0a8:FF01::2/64
ipv6 nd ra suppress all
ipv6 ospf cost 5
ipv6 ospf 100 area 0
router ospf 100
router-id 3.3.3.3
no log-adjacency-changes
network 192.168.1.0 0.0.0.255 area 0
network 3.3.3.3 0.0.0.0 area 0
ipv6 router ospf 100
router-id 3.3.3.3
passive-interface Loopback0

ルータBの設定例

interface Loopback0
ip address 1.1.1.1 255.255.255.255
ipv6 address 2002:c0a8:FFFF:FFFF::1/128
ipv6 ospf 100 area 0
interface GigabitEthernet0/1
description "routerC"
ip address 192.168.2.1 255.255.255.0
ip ospf cost 5
ipv6 address 2002:c0a8:FF02::1/64
ipv6 nd ra suppress all
ipv6 ospf cost 5
ipv6 ospf 100 area 0
interface GigabitEthernet0/2
description "routerA"
ip address 192.168.1.1 255.255.255.0
ip ospf cost 5
ipv6 address 2002:c0a8:FF01::1/64
ipv6 nd ra suppress all
ipv6 ospf cost 5
ipv6 ospf 100 area 0
router ospf 100
router-id 1.1.1.1
no log-adjacency-changes
network 192.168.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
network 1.1.1.1 0.0.0.0 area 0
ipv6 router ospf 100
router-id 1.1.1.1
passive-interface Loopback0

ルータCの設定例

interface Loopback0
ip address 2.2.2.2 255.255.255.255
ipv6 address 2002:c0a8:FFFF:FFFF::2/128
ipv6 ospf 100 area 0
interface GigabitEthernet0/0
description "routerB"
ip address 192.168.2.2 255.255.255.0
ip ospf cost 5
ipv6 address 2002:c0a8:FF02::2/64
ipv6 nd ra suppress all
ipv6 ospf cost 5
ipv6 ospf 100 area 0
router ospf 100
router-id 2.2.2.2
no log-adjacency-changes
network 192.168.2.0 0.0.0.255 area 0
network 2.2.2.2 0.0.0.0 area 0
ipv6 router ospf 100
router-id 2.2.2.2
passive-interface Loopback0

まとめ

OSPFは動作や構造など覚えることが多いですが、じぶんとしてはネイバーを張るだけ、リンクアップすればよし。って感じでいつも設定しています。
細かい設定をすることはあまりないと思います。

大体はLoopBackを利用したOSPFの設定が主流です。
ポイントさえ押さえておけば、大丈夫です。

○エンジニアの道を目指すならこちらもおすすめです!
⇒ネットワークエンジニアへの技術手順書
⇒サーバーエンジニアへの構築手順書

ITエンジニアで就職するならこちらのサイトがおすすめです!
【レバテックキャリア】



この記事が気に入ったら
いいね!しよう

Twitter で



  • この記事を書いた人
  • 最新記事

ネットワークエンジニアとしてまた一児の父として仕事とブログ作成に奮闘中!
自分の身の回りにある興味、趣味をひたすらブログで書きまとめています!
私の子供も発達障害のこともあるので色々調べたことなどアップして少しはお役に立てたらと思っております!

-ネットワーク技術
-, , ,

Copyright© GOISBLOG , 2017 All Rights Reserved.