Cisco Static Route設定(デュアルスタック)簡単設定!


今回はCiscoのNW機器のスタティックルートの設定をデュアルスタックで設定したメモを記載します。
いろんな意味で凄く重要なルーティングの設定なので、覚えておきましょう。

Ciscoの機器はネットワークエンジニアを目指す方にはほぼ必須といっていいほど全世界、もちろん日本にもシェアが多いものです。

コマンドの体系はCisco以外のメーカーでもCiscoライクに作られたOSが結構多いですし、Ciscoのコマンドをある程度覚えておけば、他メーカーの機器もある程度触れます。

ネットワークエンジニアを目指す方はまずCiscoを勉強されるといいですね!


CiscoのStaticRoute(スタティックルート)設定は難しく考えることは無い

構成は以下の図の通りとなります。

cisco_static_route

IPv6 StaticRouteの設定はipv6コマンドを頭につけて、後はipv4スタティック設定とほぼ、変わらないです。
特にこれといったコマンドも書かなくて良いので大丈夫です。

IPv4との大きな違いと言えば、アドレス体系と、コマンド設定に始めに”IPv6”コマンドを設定する事です。
ただこれだけです。

ただし、そもそも論ですが、IPv6アドレスの意味を分かっていないとやっても難しいです。
IPv6アドレスはIPv4アドレスと違い、「.」で区切らず、「:」で区切ります。

しかも、IPv4は4つのブロック(4オクテット)でアドレスを構成していますが、IPv6は8ブロックでアドレスを構成しています。

ルータBのインターフェース設定例

ipv6 unicast-routing
interface GigabitEthernet0/1
description XXXX
ip address 192.168.2.1 255.255.255.0
negotiation auto
ipv6 address 2002:c0a8:FF00:2::1/64
ipv6 enable
ipv6 nd ra suppress all
ipv6 unicast-routing
interface GigabitEthernet0/2
description XXXX
ip address 192.168.1.1 255.255.255.0
negotiation auto
ipv6 address 2002:c0a8:FF00:1::1/64
ipv6 enable
ipv6 nd ra suppress all


ルータBのstatic route設定例

ip route 2.2.2.2 0.0.0.0 192.168.2.2
ip route 3.3.3.3 0.0.0.0 192.168.1.2
ipv6 route 2002:c0a8:FFFF:FFFF::2/128 2002:c0a8:FF00:2::2
ipv6 route 2002:c0a8:FFFF:FFFF::3/128 2002:c0a8:FF00:1::2

ついでにデフォルトルートの設定も

デフォルトルートの設定は以下となる

ip route 0.0.0.0 0.0.0.0 {ネクストホップアドレスor送信インターフェース}
ipv6 route ::/0 {ネクストホップアドレスor送信インターフェース}

まとめ

スタティックルートはルーティングの基本です。
ネクストホップを使って、その先のセグメント(ネットワーク)へ通信させる技術です。

始めの頃はよく使い方を間違ったり、混乱したり大変でした。じぶん頭悪かったんで。。。
スタティックルートの設定は他のプロトコルの設定に比べて凄く楽ですが、とても重要なルーティングの設定です。

なんだかんだで、いろんなところで使われるので重要な設定です。
何事も基本が大事なので一つ一つの設定を確実に覚えていきましょう。

それでは!


関連記事


コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

日本語が含まれない投稿は無視されますのでご注意ください。(スパム対策)

ABOUTこの記事をかいた人

blank

インターネット関連のSEをやっています。 ネットワーク、サーバー、ストレージ、仮想基盤まで幅広く手を出しており、MVNOの構築経験もあります。 現在は、Pythonを使ったプログラミングの開発をしネットワークの自動化ツールを作成しています! Pythonの入門書も作成しているので、ぜひ参考にしてください!