ネットワークエンジニア系ブログ。エンターテイメント、おすすめ映画、本、キッズ系などお役立ち情報を紹介!

GOISBLOG

medium_14857345211

ネットワーク技術

H3Cネットワークコマンドまとめ

投稿日:2014年11月7日 更新日:

HPが出しているスイッチ「H3C」のコマンドをメモしました。
このH3Cは他のNW機器と比べて結構コマンド体系が違っています。

コンフィグはCiscoに近いですが、「show」コマンドなんて存在しません。
H3Cは「display」コマンドを使用します。

ついでに「exit」ではコマンドは弾かれます。この機器は「quit」を使うので頭に入れておいてください。

photo credit: seeweb via photopin cc

H3CはHP独特のネットワークコマンドです

まずは、「display」コマンドのメモです。「show」ではないので注意しておくこと!
結構重要というか、便利なコマンドもあるので覚えておきましょう。

  • OSバージョン確認
  • display version
    
  • OSの格納先およびバージョンの確認
  • display boot-loader
    
  • 機器情報(型番、シリアルナンバー、MACアドレス等)
  • display device manuinfo
    
  • ファン状態の確認
  • display fan
    
  • 電源の状態
  • display power
    
  • fibテーブルの確認(スイッチングの宛先)
  • display fib
    
  • ルーティング情報
  • display ip routing-table
    
  • vlan情報
  • display vlan all
    
  • リンクアグリゲーション情報
  • display link-aggregation summary
    display link-aggregation verbose
    
  • コンフィグ設定情報
  • display current-configuration
    
スポンサーリンク


設定コマンド

次は、コンフィグの設定例です。
H3CはL2スイッチなので、基本が「vlan」で設定していく感じでしょうか。

  • Ciscoではコンフィグ設定するときは特権モードで「configure terminal」コマンドを使用しますが、H3Cは以下のコマンドを使用します。
  • system−view
    
  • vlan設定
  • interface Vlan-interface100
     ip address 10.0.0.1 255.255.255.0
    
  • アクセスvlan設定
  • interface GigabitEthernet1/0/1
     description "Test"
     port access vlan 100
    
  • リンクアグリゲーション設定
  • interface Bridge-Aggregation1
     port link-type trunk
     undo port trunk permit vlan 1
     port trunk permit vlan 100
     link-aggregation mode dynamic
    
    
    interface GigabitEthernet1/0/1
     description "link-agg"
     port link-type trunk
     undo port trunk permit vlan 1
     port trunk permit vlan 100
     port link-aggregation group 1
    
  • スタティックルート設定例
  • ip route-static 0.0.0.0 0.0.0.0 1.1.1.1
    ip route-static 10.0.0.0 255.255.255.0 2.0.0.1
    
  • NTPサーバ設定例
  • ntp-service unicast-server 10.0.0.1
    
  • snmp設定例
  • snmp-agent
    snmp-agent community write public(任意の名前)
    snmp-agent sys-info version all
    snmp-agent target-host trap address udp-domain 1.1.1.1 params securityname public(任意の名前)
    
  • アクセスリスト設定
  • acl number 2001
     rule 10 permit source 1.1.1.1 0.0.0.127
     rule 20 permit source 2.2.2.2 0.0.0.127
    
  • enableパスワードの設定
  • super password level 3 cipher xxxx
    
  • ssh設定
  • ssh server enable
    
  • telnet設定
  • user-interface vty 0 4 
    
  • 最後は、コンフィグを保存するコマンドです。
  • save
    

こんな感じでメモっておきます。

この記事が気に入ったら
いいね!しよう

Twitter で
スポンサーリンク

-ネットワーク技術
-

Copyright© GOISBLOG , 2016 AllRights Reserved.