ネットワークエンジニア系ブログ。健康、エンターテイメント、映画・ドラマ、本、キッズ系、FXまで!お役立ち情報を紹介!

GOISBLOG

ネットワーク技術

Cisco Vlan設定(デュアルスタック)のコマンド

更新日:

今回はCiscoでVlan(デュアルスタック)の設定をします。
インターフェースの設定同様、思ったほど難しくありません。

IPv6のアドレス体系を把握しておけば、後の設定はIPv4とほぼ変わりません。


TVでも話題になった自宅で無料でオンラインブートキャンプが体験できるようになりました!
プログラミングのオンラインスクールCodeCamp

※資料ダウンロード(無料)はこちらから!
【CodeCamp(コードキャンプ)】公式案内

Vlanデュアルスタック(IPv4/IPv6)って思ったほど難しくないです。

構成図
Cisco_Vlan

Vlanというよりは、ルータのサブインターフェースにアドレスを振ったというかんじだろうか。
今回はルータでのVlan設定をメモしています。

以下、コマンドでも見られるようにvlanデュアルスタックの設定はIPv6アドレスを追記するだけです。
※現在はインターフェースに”IPv6 enable”の設定が無くても大丈夫見たいです。

A)の設定例

ipv6 unicast-routing
interface GigabitEthernet0/1.10
encapsulation dot1Q 10
ip address 192.168.1.1 255.255.255.0
ipv6 address 2001:FFFF:FFFF:5::1/64
ipv6 enable

B)の設定例

ipv6 unicast-routing
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.1.2 255.255.255.0
ipv6 address 2001:FFFF:FFFF:5::2/64
ipv6 enable

IPv4で設定していた内容とほとんど変わりはない

L3スイッチであれば対象インターフェースへswitchportコマンドを設定して

interface vlan

へアドレスを振る感じです。
ということでインターフェースへアドレスを割り振る設定はこの記事で確認してください。

初心者でも簡単設定!Cisco interface設定(デュアルスタック)

まとめ

デュアルスタック(IPv4、IPv6)と言っても、始めは抵抗感がありますが、実際やってみればたいした事はないです。
IPv6のアドレス体系さえ覚えれば、アドレスを一つ追加するだけって感じです。

上位プロトコル(OSPF、BGPなど)の設定でも、何度か設定してみればなれてくるはずです。
※ただし、showコマンドの出力結果(IPv6)がすんごい醜くって、なれるのに時間が掛かりますが。。。

○エンジニアの道を目指すならこちらもおすすめです!
⇒ネットワークエンジニアへの技術手順書
⇒サーバーエンジニアへの構築手順書

Linuxアカデミーの資料が無料請求できます!
リナックスアカデミー【公式サイト】



この記事が気に入ったら
いいね!しよう

Twitter で



  • この記事を書いた人
  • 最新記事

ネットワークエンジニアとしてまた一児の父として仕事とブログ作成に奮闘中! 自分の身の回りにある興味、趣味をひたすらブログで書きまとめています! 私の子供も発達障害のこともあるので色々調べたことなどアップして少しはお役に立てたらと思っております!

-ネットワーク技術
-,

Copyright© GOISBLOG , 2017 All Rights Reserved.